Issue on working hours and service hours (from – to)

Home Forums Plugins Forum Apoint Issue on working hours and service hours (from – to)

This topic contains 3 replies, has 2 voices, and was last updated by  Kenus 1 month, 2 weeks ago.

  • Author
    Posts
  • #5547

    brunochacon
    Participant

    Hi there.

    I’ve been trying to setup your plugin to a client and I’m facing a problem (dificult of mine, I believe)…

    My client has bike classes at multiple times at a day, for example:
    – MON to THU, 07:15 AM to 08:15 AM / 08:15 AM to 09:15 AM / 06:15 PM to 07:15 PM / 07:15 PM to 08:15 PM

    On SERVICE DETAILS I’ve set 0 minutes to break time (apoint-print-service-detail.png);

    On SERVICE DURATION I’ve set the Service duration to 1 hour for a specific price (apoint-print-service-duration.png);

    On SCHEDULE I’ve tried multiple different ways, such as:
    – 07:15 – 09:15 / And 07:15 – 08:15, 08:15 – 09:15;
    – 18:15 – 20:15 / And 18:15 – 19:15, 19:15 – 20:15.
    – You may see the result of that on file (apoint-print-frontend.png)

    Now, if I go to the GENERAL SETTINGS and change the time step to 60 minutes, apparently the front end seems to fix, but still has a problem, because it shows, on my example: 07:15 – 07:15 | 08:15 – 08:15 (instead of showing 07:15 – 08:15 | 08:15 – 09:15, once I’ve defined this service has one hour of duration and zero break time). See here (apoint-print-frontend-afterchange.png)

    Also, after changing the GENERAL SETTINGS time step to 60 minutes, my SCHEDULE service becomes empty, because you are assuming all my services that has one hour of duration should start on a perfect time (available: 0:00, 1:00, 2:00, 3:00, 4:00, etc).

    I’m not so sure if I’m doing right, but I’m following your documentation and it doesn’t seems to work as on your demo preview. Would you please help me?

    Thanks for your time!

    Attachments:
    You must be logged in to view attached files.

You must be logged in to reply to this topic.